aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Mathieson <martin.r.mathieson@googlemail.com>2012-09-24 10:23:20 +0000
committerMartin Mathieson <martin.r.mathieson@googlemail.com>2012-09-24 10:23:20 +0000
commit60fb63783a06d76fea9d5e7b4aadcc6fb788c2e1 (patch)
tree4126610951deff7711302354939350d520823cd1 /Makefile.am
parentd06c9779a237eb90ca1bb312bc30f6648d09b523 (diff)
From Jim Young, bug 7745.
Add Makefile support for reordercap. svn path=/trunk/; revision=45090
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 62d01d8bf9..ecf8dd7448 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,10 +46,11 @@ bin_PROGRAMS = \
@randpkt_bin@ \
@dftest_bin@ \
@dumpcap_bin@ \
+ @reordercap_bin@ \
@rawshark_bin@
EXTRA_PROGRAMS = wireshark tshark capinfos editcap mergecap dftest \
- randpkt text2pcap dumpcap rawshark
+ randpkt text2pcap dumpcap reordercap rawshark
#
# Wireshark configuration files are put in $(pkgdatadir).
@@ -446,6 +447,13 @@ editcap_LDADD = \
@GLIB_LIBS@
editcap_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
+# Libraries with which to link reordercap.
+reordercap_LDADD = \
+ wiretap/libwiretap.la \
+ wsutil/libwsutil.la \
+ @GLIB_LIBS@
+reordercap_CFLAGS = $(AM_CLEAN_CFLAGS)
+
# Libraries with which to link randpkt.
randpkt_LDADD = \
wiretap/libwiretap.la \
@@ -713,6 +721,7 @@ EXTRA_DIST = \
image/nsis-unchecked.bmp \
image/rawshark.rc.in \
image/README.image \
+ image/reordercap.rc.in \
image/status.qrc \
image/stock_dialog_error_48.xpm \
image/stock_dialog_info_48.xpm \
@@ -837,6 +846,7 @@ EXTRA_DIST = \
$(ui_DATA) \
$(wimaxasncp_DATA) \
randpkt.c \
+ reordercap.c \
smi_modules \
text2pcap-scanner.l \
text2pcap.c \