aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-07-06 16:42:30 +0000
committerGuy Harris <guy@alum.mit.edu>2013-07-06 16:42:30 +0000
commit519c5affa2f9713a9f196c78ebf44b2308ff4ef1 (patch)
treeb8643ffb40aaba4a4ddc1b55630b3ce2581c6e45 /Makefile.am
parent5a744f4afa70c75cc06bbeff5825657876d9c6f2 (diff)
Add a --enable-osx-deploy-target option to set the deployment target
when building for OS X; that causes the MACOSX_DEPLOYMENT_TARGET environment variable to be set when building (so that, for example, we don't use linker features available on the version on which we're building but not on the minimum OS version for which we're building), and causes the SDK for that version to be used (so that, for example, we don't link with libraries with later version numbers than the ones provided with the OS version for which we're building). svn path=/trunk/; revision=50410
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 04be30ba21..f594530a65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1138,7 +1138,7 @@ osx-app: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) packaging/macosx/Info.plist
rm -rf $(stagedir) ; \
$(MAKE) DESTDIR=$(stagedir) install; \
cd $(srcdir)/packaging/macosx ; \
- ./osx-app.sh -bp ../staging/$(PACKAGE).inst$(bindir) ; \
+ ./osx-app.sh @OSX_APP_FLAGS@ -bp ../staging/$(PACKAGE).inst$(bindir) ; \
else \
echo "Error: OS X packaging tools not found." ; \
echo "Package build abandoned." ; \