aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2015-01-23 07:36:50 -0500
committerJeff Morriss <jeff.morriss.ws@gmail.com>2015-02-04 00:53:29 +0000
commit4fe8ca05767f2a4ec160eae412f5b2fd0ee0903b (patch)
tree5a107c11b091f946ae461314d34180e13951c177 /Makefile.am
parent0e74e8b0cc3a02457b05c1afd83fb02ba7255927 (diff)
Simplify how we find Lua and expand the places we look.
First, it appears some packagers actually ship a pkg-config file for Lua. Try to use it. (Unfortunately the package name varies so we have to try several package names.) If that fails, try to find Lua directly, accounting for the various naming conventions we've seen. Bug: 10475 Bug: 10572 Change-Id: I82e789c466a488dc12431cdd90c49b4c1052414a Reviewed-on: https://code.wireshark.org/review/6756 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d86e95bd1..4e34ed8ce8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -645,7 +645,7 @@ dumpcap_LDFLAGS = $(PIE_LDFLAGS)
# Common headers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap \
$(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) \
- @LUA_INCLUDES@ $(SBC_CFLAGS) -DTOP_SRCDIR=\"$(abs_top_srcdir)\"
+ @LUA_CFLAGS@ $(SBC_CFLAGS) -DTOP_SRCDIR=\"$(abs_top_srcdir)\"
#
# Build the version string