aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2006-02-15 19:20:36 +0000
committerGuy Harris <guy@alum.mit.edu>2006-02-15 19:20:36 +0000
commit3442ed9e325921c56935c08254f428673650a509 (patch)
tree1c1d556e61c5e36588a51342d5469102336e3aa1 /Makefile.am
parent1ee7aa4476b30e99bd137394907a968bf5669479 (diff)
Check for getopt in the configure script, as we do for other routines
not available on all platforms. Include getopt.c in EXTRA_ethereal_SOURCES and include getopt.h in EXTRA_ethereal_INCLUDES, as we do with the other files that supply routines not available on all platforms, rather than always including them in the source for dumpcap. svn path=/trunk/; revision=17311
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d984a1058d..47030c2751 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -268,7 +268,7 @@ endif # HAVE_PLUGINS
# we should probably split this into stuff needed both
# by ethereal and tethereal and stuff needed only by one or the
# other.
-ethereal_optional_objects = @SNPRINTF_O@ @STRERROR_O@ \
+ethereal_optional_objects = @GETOPT_O@ @SNPRINTF_O@ @STRERROR_O@ \
@STRCASECMP_O@ @STRNCASECMP_O@ @MKSTEMP_O@ @STRPTIME_O@
# Additional libs that I know how to build. These will be
@@ -565,8 +565,6 @@ EXTRA_DIST = \
ethereal_be.py \
ethereal_gen.py \
ethereal.desktop \
- getopt.c \
- getopt.h \
idl2eth.sh \
image/Ethereal.icns \
image/Makefile.nmake \