aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-05-29 22:23:49 +0100
committerJoão Valverde <j@v6e.pt>2017-05-30 01:56:07 +0000
commit1a8991e875f1e976e1fd0ed63e6e254548e57703 (patch)
treea2050a4031bf9970558a9225829da064b18218d5 /Makefile.am
parent7c2073a7e8ef76479b278fdb32533bf76d3f6896 (diff)
sharkd: Fix build using system Speex library (autotools)
Change-Id: I1798f3dc76704c646d67d11533f8dc32ebab7401 Reviewed-on: https://code.wireshark.org/review/21793 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 519e0043a2..ff2bc694ee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -587,6 +587,10 @@ sharkd_SOURCES = \
sharkd_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS)
+if HAVE_SPEEXDSP
+sharkd_CPPFLAGS += $(SPEEXDSP_CFLAGS)
+endif
+
sharkd_LDFLAGS = $(AM_LDFLAGS) $(EXTRALINKFLAGS)
# Libraries and plugin flags with which to link sharkd.
@@ -604,6 +608,10 @@ sharkd_LDADD = \
@SYSTEMCONFIGURATION_FRAMEWORKS@ \
@COREFOUNDATION_FRAMEWORKS@
+if HAVE_SPEEXDSP
+sharkd_LDADD += $(SPEEXDSP_LIBS)
+endif
+
text2pcap_SOURCES = \
text2pcap.c \
text2pcap-scanner.l \