aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoland Knall <rknall@gmail.com>2016-06-28 21:34:46 +0200
committerRoland Knall <rknall@gmail.com>2016-07-05 11:54:43 +0000
commitf2786bc8ff5ea25fd1c36d3ebf83a29277ee662b (patch)
tree0e0f3c89505d3257ab5510c55eff956543814e40 /Makefile.am
parentfdd87a1e41db7039b0af5bb15f40b83db1ca3a96 (diff)
extcap: Remove g_spawn_helper support
Move g_spawn to separate file and implement functions to use Windows based method of spawning, instead of the glib based version Change-Id: Ibae03d834ec86531eba37dc8768fbf17ddadf57f Reviewed-on: https://code.wireshark.org/review/16049 Petri-Dish: Roland Knall <rknall@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a4458e0a6d..a6149110c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -383,11 +383,13 @@ GENERATED_FILES = $(GENERATED_C_FILES) $(GENERATED_HEADER_FILES)
EXTCAP_COMMON_SRC = \
extcap.c \
- extcap_parser.c
+ extcap_parser.c \
+ extcap_spawn.c
EXTCAP_COMMON_INCLUDES = \
extcap.h \
- extcap_parser.h
+ extcap_parser.h \
+ extcap_spawn.h
# sources common for wireshark, tshark, and rawshark
SHARK_COMMON_SRC = \