aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-03-13 09:21:01 -0700
committerGerald Combs <gerald@wireshark.org>2015-03-13 22:41:40 +0000
commitf074647d2b6b16af34a2a9595adffd78c3a2dfe3 (patch)
tree89e929cb7e60a9dd4b9fe8dfa17a43f89b72fe73 /Makefile.am
parent8f9e543d4ec168ba3f85bc37ba6236d08c910a53 (diff)
Add a test-programs target everywhere.
Add a "test-programs" target to each toolchain which builds each unit test executable. "test-programs" must now be built before running the unit test suite. Change-Id: I9317a1e305d987f244c4bd8b4a7f05d11fed7090 Reviewed-on: https://code.wireshark.org/review/7673 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a78af1e0c..12967ed90b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1590,6 +1590,9 @@ osx-install: osx-app
cp -pr $(srcdir)/packaging/macosx/Wireshark.app /Applications ; \
fi
+test-programs:
+ cd epan && $(MAKE) $@
+
clean-local:
rm -rf $(top_stagedir)