aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2016-07-04 10:36:20 +0200
committerAnders Broman <a.broman58@gmail.com>2016-07-10 14:56:59 +0000
commitea0b2e0d3677c1afd190a43fdee3b32a4cf0912a (patch)
tree21659d3d65a91940d37437cac313c58b49b6f1ad /Makefile.am
parentdec3e2e8aa343f5acdc61df67826b0951b13a663 (diff)
Makefile: Install wireshark.pc too
In my previous patches (8454f2a20e2 and ea16a84ef51) I've tried to make the pkg-config file more robust. But what I had completely forgot about is that the file was never installed by our Makefile rather than we relied on distribution maintainers to be smart and make the package install the file instead. I've realized this as soon as I've tried to update wireshark in my system. Change-Id: Idb60157a51ea1dd0afd6cfac695bfa5760485241 Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Reviewed-on: https://code.wireshark.org/review/16279 Reviewed-by: Jaap Keuter <jaap.keuter@xs4all.nl> Petri-Dish: Jaap Keuter <jaap.keuter@xs4all.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a6149110c1..ed3aafd1cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,6 +57,9 @@ EXTRA_PROGRAMS = wireshark-gtk wireshark tshark tfshark capinfos captype \
dist_pkgdata_DATA = COPYING manuf services cfilters colorfilters dfilters \
smi_modules ipmap.html pdml2html.xsl
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = wireshark.pc
+
#
# Install global profiles in the "profiles" subdirectory
#