aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-04-26 17:49:00 +0000
committerGerald Combs <gerald@wireshark.org>2013-04-26 17:49:00 +0000
commitea5829c50bcb5a143cbf6c5ecefa4705987de532 (patch)
tree258d375d4ffb533fd28152455eafed025f94188b /Makefile.am
parent32d63847259079d65230d40757524c12e3fba742 (diff)
Add some Doxygen checks.
svn path=/trunk/; revision=49051
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f7de5d30d..ebf73b738b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1152,10 +1152,14 @@ checkapi: checkapi_local
cd wsutil && $(MAKE) checkapi
wsar_html: doxygen.cfg doxygen_global.cfg
+if HAVE_DOXYGEN
$(DOXYGEN) doxygen.cfg
cd epan && $(MAKE) $@
cd ui && $(MAKE) $@
+endif
wsar-zip: wsar_html
+if HAVE_DOXYGEN
rm -f wsar_html.zip
zip -rq wsar_html.zip wsar_html
+endif