aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2013-04-26 00:07:42 +0000
committerGerald Combs <gerald@wireshark.org>2013-04-26 00:07:42 +0000
commite6434ae19ec7f731a7e52cf34d4e2ac5cfc53336 (patch)
treec573fa0bed63eb20ff976d398b2326c775ef2804 /Makefile.am
parentc3d7f57f58bcc7062b9b1bb8cc438e0b57806505 (diff)
Update the main, epan, and ui Doxygen configuration files. Change the
output directory to wsar_html (Wireshark API Reference HTML) to match the Docbook naming convention. In each doxygen.cfg.in move the doxygen_global.cfg to the top of the file so that our local definitions don't get clobbered. Add makefile targets for wsar_html and wsar-zip. svn path=/trunk/; revision=49043
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ba011c53ee..9f7de5d30d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1150,3 +1150,12 @@ checkapi: checkapi_local
cd epan/dissectors && $(MAKE) checkapi
cd plugins && $(MAKE) checkapi
cd wsutil && $(MAKE) checkapi
+
+wsar_html: doxygen.cfg doxygen_global.cfg
+ $(DOXYGEN) doxygen.cfg
+ cd epan && $(MAKE) $@
+ cd ui && $(MAKE) $@
+
+wsar-zip: wsar_html
+ rm -f wsar_html.zip
+ zip -rq wsar_html.zip wsar_html