aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-11-26 23:43:18 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-11-26 23:43:18 +0000
commit69017ac3bdc0877765817e5cd50279a78da2fc11 (patch)
treef67d8f45bfc7c810e203c694b51f63bb721a8ddb /Makefile.am
parentcc538dbb6c7f1f31552f39809a241b43442acea5 (diff)
Overhaul rpm-building options a bit: as suggested by Anders, have the RPM follow
./configure's options for gtk2 vs gtk3 vs qt. Make it possible to not build the GNOME package (now both UIs' packages are optional). I think Chris requested this a while ago. If this works out it may make sense to control the rest of the options via ./configure . svn path=/trunk/; revision=53607
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 671155123f..3ea7abaab6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1090,6 +1090,8 @@ stagedir=$(top_stagedir)/$(PACKAGE).inst
host_cpu=@host_cpu@
host_os=@host_os@
+solaris-package: svr4-package
+
svr4-package: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA)
@if test x$(HAVE_SVR4_PACKAGING) = xyes ; then \
rm -rf $(stagedir) ; \
@@ -1104,7 +1106,6 @@ svr4-package: $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA)
echo "Package build abandoned." ; \
fi
-solaris-package: svr4-package
rpm_topdir=`cd $(top_builddir) && pwd`/packaging/rpm
rpm-package: dist
@@ -1114,7 +1115,8 @@ rpm-package: dist
cd SOURCES ; \
ln -sf ../../../$(distdir).tar.bz2 ; \
cd .. ; \
- rpmbuild --define "_topdir `cd . && pwd`" --define "_prefix $(prefix)" --clean -ba SPECS/wireshark.spec && \
+ rpmbuild --define "_topdir `cd . && pwd`" --define "_prefix $(prefix)" \
+ @RPMBUILD_WITH_ARGS@ --clean -ba SPECS/wireshark.spec && \
echo "Package successfully built in `pwd`/RPMS." && \
rm -f SOURCES/$(distdir).tar.bz2 $(distdir).tar.bz2 ; \
else \