aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-06-26 15:12:50 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-06-26 15:12:50 +0000
commit681efb2de391bc2c943cba5e1a67e0112fdf6417 (patch)
tree5911893397b0c83a25f08ff770707a4a7ac1784f /Makefile.am
parent8da89ad091569222f3e3e21ded53fd48bc1f95d3 (diff)
Don't link wireshark against the Qt libraries and don't like wireshark-qt
against the Gtk+ libraries. (I didn't notice this before because the resulting programs aren't, on my system, actually linked against the libraries they don't use--presumably because of the "-Wl,--as-needed" flag.) svn path=/trunk/; revision=50170
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 913697d53e..cd9da78cf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ bin_PROGRAMS = \
@dumpcap_bin@ \
@reordercap_bin@ \
@rawshark_bin@ \
- @echld_test_bin@
+ @echld_test_bin@
EXTRA_PROGRAMS = wireshark wireshark-qt tshark capinfos editcap mergecap \
dftest randpkt text2pcap dumpcap reordercap rawshark wireshark_cxx \
@@ -379,8 +379,6 @@ wireshark_ldadd = \
@LIBGNUTLS_LIBS@ \
@LIBSMI_LDFLAGS@ \
@PORTAUDIO_LIBS@ \
- @GTK_LIBS@ \
- @Qt_LIBS@ \
@GLIB_LIBS@ \
-lm
@@ -388,7 +386,7 @@ if HAVE_Qt
wireshark_qt_SOURCES = $(WIRESHARK_COMMON_SRC)
wireshark_qt_INCLUDES = $(WIRESHARK_COMMON_INCLUDES)
wireshark_qt_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
-wireshark_qt_LDADD = ui/qt/libqtui.a $(wireshark_ldadd)
+wireshark_qt_LDADD = ui/qt/libqtui.a $(wireshark_ldadd) @Qt_LIBS@
wireshark_qt_LINK = $(CXXLINK)
endif
@@ -396,7 +394,7 @@ if HAVE_GTK
wireshark_SOURCES = $(WIRESHARK_COMMON_SRC)
wireshark_INCLUDES = $(WIRESHARK_COMMON_INCLUDES)
wireshark_CFLAGS = $(AM_CLEAN_CFLAGS) $(py_dissectors_dir)
-wireshark_LDADD = ui/gtk/libgtkui.a $(wireshark_ldadd)
+wireshark_LDADD = ui/gtk/libgtkui.a $(wireshark_ldadd) @GTK_LIBS@
wireshark_LINK = $(LINK)
endif