aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-02 13:27:00 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-02 20:27:28 +0000
commit2c9d2bea32238223634ae975cfd4e682ba1a0b2b (patch)
tree1b80cca66826e31c2cb65e1c76500827e6223d21 /Makefile.am
parent980893a15afba3d4ed654734a386009c27c18358 (diff)
Fail if any of the install-exec-hook commands fails.
Hopefully, this will mean that somebody doing a set-UID/set-GID/setcap installation as themselves rather than as root will not "succeed" but leave dumpcap installed without enhanced privileges, so the underlying problem in bugs such as bug 10247 will be more obvious. Change-Id: I34393bc2c9ea4dc59854a08524edb4f65e79730b Reviewed-on: https://code.wireshark.org/review/2781 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a189a779e..424a9d2635 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1040,15 +1040,15 @@ EXTRA_DIST = \
install-exec-hook:
if HAVE_DUMPCAP_GROUP
- -chgrp $(DUMPCAP_GROUP) $(DESTDIR)$(bindir)/dumpcap
+ chgrp $(DUMPCAP_GROUP) $(DESTDIR)$(bindir)/dumpcap
endif
if SETCAP_INSTALL
- -$(SETCAP) cap_net_raw,cap_net_admin+ep $(DESTDIR)$(bindir)/dumpcap
- -chmod o-rws $(DESTDIR)$(bindir)/dumpcap
+ $(SETCAP) cap_net_raw,cap_net_admin+ep $(DESTDIR)$(bindir)/dumpcap
+ chmod o-rws $(DESTDIR)$(bindir)/dumpcap
else
if SETUID_INSTALL
- -chmod o-rws $(DESTDIR)$(bindir)/dumpcap
- -chmod +s $(DESTDIR)$(bindir)/dumpcap
+ chmod o-rws $(DESTDIR)$(bindir)/dumpcap
+ chmod +s $(DESTDIR)$(bindir)/dumpcap
endif
endif