aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuis Ontanon <luis.ontanon@gmail.com>2013-06-25 21:09:29 +0000
committerLuis Ontanon <luis.ontanon@gmail.com>2013-06-25 21:09:29 +0000
commit0a060270b37870c8273d4dc8e57d13b683fd7a0b (patch)
tree4132f11f41190637009b6cd69271d0924a117136 /Makefile.am
parent9216d338f0536ed0f87035e17c904835984f8ddf (diff)
Last changes to autofoo, rename the files as they live now in their own dir...
svn path=/trunk/; revision=50152
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 69349653e3..913697d53e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -550,6 +550,10 @@ echld_test_LDADD = \
@C_ARES_LIBS@ \
@ADNS_LIBS@
+echld_test_DEPENDENCIES = \
+ echld/libechld.la \
+ epan/libwireshark.la
+
echld_test_CFLAGS = $(AM_CLEAN_CFLAGS)
@@ -1027,15 +1031,9 @@ endif
DIST_SUBDIRS = asn1 codecs doc epan echld ui ui/cli ui/gtk ui/qt help packaging plugins tools wiretap wsutil docbook
if HAVE_PLUGINS
-SDIRS = tools wsutil wiretap epan plugins packaging help ui @wireshark_SUBDIRS@ ui/cli . doc
-else
-SDIRS = tools wsutil wiretap epan packaging help ui @wireshark_SUBDIRS@ ui/cli . doc
-endif
-
-if HAVE_ECHLD
-SUBDIRS = echld $(SDIRS)
+SUBDIRS = tools wsutil wiretap epan @echld_dir@ plugins packaging help ui @wireshark_SUBDIRS@ ui/cli . doc
else
-SUBDIRS = $(SDIRS)
+SUBDIRS = tools wsutil wiretap epan @echld_dir@ packaging help ui @wireshark_SUBDIRS@ ui/cli . doc
endif
help/faq.txt: $(srcdir)/help/faq.py