aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-10-21 16:05:10 -0700
committerAnders Broman <a.broman58@gmail.com>2016-10-22 11:21:09 +0000
commite85882940419dd9ce012489689e13ae4b18be04e (patch)
tree3acf7d8bd15672e5a96ab5abd9407dfb1149a049 /CMakeLists.txt
parent7dfaec969e67e3aa14b9763d804802ef614c9ddd (diff)
CMake: Disable Qt4 && (Windows || macOS).
We haven't built the Windows and macOS installers with Qt4 for quite some time. In the case of macOS+Qt4 it looks like there's a problem with the main screen size (bug 13009) and it's a safe bet that there are other problems. There's not much we can do exept say "don't do that." Do so at build time rather than after the user has installed Wireshark and is trying to use it. Change-Id: I22f47b9705ea044238046676b6336aa5feab3f60 Reviewed-on: https://code.wireshark.org/review/18364 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5403a5243..2a4811ed96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1057,7 +1057,7 @@ if (Qt5Widgets_FOUND)
set(MOC_OPTIONS -nn)
endif()
# If Qt4: QT_LIBRARIES and QT_INCLUDES are not set above. They require extra magic
-elseif(QT_FOUND)
+elseif(Qt4_FOUND)
include(${QT_USE_FILE})
include_directories(${QT_INCLUDE_DIR})
message(STATUS "Qt includes: ${QT_INCLUDE_DIR}")
@@ -1075,6 +1075,9 @@ elseif(QT_FOUND)
set(MOC_OPTIONS -nn)
endif()
endif()
+ if(WIN32 OR APPLE)
+ message(FATAL_ERROR "Windows and macOS builds should use Qt5.")
+ endif()
endif()
if(ENABLE_CHECKHF_CONFLICT)