aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-07-12 19:54:15 -0700
committerGuy Harris <guy@alum.mit.edu>2015-07-13 02:55:01 +0000
commitc6aa2b5b2c687f855d0c0a5a1fa7ea53f4b89415 (patch)
treea66708f8f4f38cc139f1f1d954138f0bd20c17d2 /CMakeLists.txt
parentc305f08921feb30f5411bc8f8e0b01ebf1cfbe2e (diff)
Don't add rpaths with CMake, either; osx-app.sh will do so.
Change-Id: Ie8f39e5e89ed8dc21c66ee7f1235c406c3028304 Reviewed-on: https://code.wireshark.org/review/9613 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9611b833e0..14de0bda2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1623,17 +1623,9 @@ if(ENABLE_APPLICATION_BUNDLE)
# with a static version installed in /usr/local/lib rather than
# the system version in /usr/lib).
#
- # Also add -Wl,-rpath,@executable_path/../Frameworks,
- # -Wl,-rpath,@executable_path/../lib and
- # -Wl,-rpath,/usr/local/lib, so that, if we build an app
- # bundle, we can tweak all the executable images, shared
- # libraries, and plugins in the bundle to look for non-system
- # libraries in the rpath, rather than having a script tweak
- # DYLD_LIBRARY_PATH.
- #
set(CMAKE_EXE_LINKER_FLAGS
- "-Wl,-headerpad_max_install_names -Wl,-search_paths_first -Wl,-rpath,@executable_path/../Frameworks -Wl,-rpath,@executable_path/../lib -Wl,-rpath,/usr/local/lib ${CMAKE_EXE_LINKER_FLAGS}"
+ "-Wl,-headerpad_max_install_names -Wl,-search_paths_first ${CMAKE_EXE_LINKER_FLAGS}"
)
# Add files to the app bundle