aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-09-26 10:43:13 -0700
committerGerald Combs <gerald@wireshark.org>2019-09-26 17:52:43 +0000
commitaf793b19d03b662288c908b627a462d07d5a76fc (patch)
treeaebec4bbbc2c543ec28f0f2cbf7bdb400b9e0970 /CMakeLists.txt
parent2cb18634d8f828ee263cc4e302dd6b3c54f7141f (diff)
macOS: Sign our .dmg.
Add osx-dmg.sh back and make it a simple wrapper around dmgbuild and codesign. Change-Id: I0baa21fd971aa1b06e1a6700881cd7625dffff35 Reviewed-on: https://code.wireshark.org/review/34629 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2db23ff676..6f7f08bb8e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1559,6 +1559,7 @@ set(CFG_OUT_FILES
packaging/macosx/Info.plist
packaging/macosx/dmgbuild-settings.py
packaging/macosx/osx-app.sh
+ packaging/macosx/osx-dmg.sh
packaging/source/git-export-release.sh
wireshark.pc
)
@@ -2899,11 +2900,7 @@ if(ENABLE_APPLICATION_BUNDLE)
add_dependencies(dmg_package_prep read_me_first_html)
ADD_CUSTOM_TARGET( dmg_package
- COMMAND ${DMGBUILD_EXECUTABLE}
- --no-hidpi
- -s ${CMAKE_BINARY_DIR}/packaging/macosx/dmgbuild-settings.py
- "Wireshark ${VERSION}"
- "Wireshark ${VERSION} Intel 64.dmg"
+ COMMAND bash -x ${CMAKE_BINARY_DIR}/packaging/macosx/osx-dmg.sh
# Unlike nsis_package_prep + nsis_package, we can add a direct
# dependency here.
DEPENDS dmg_package_prep
@@ -3383,6 +3380,7 @@ if(SHELLCHECK_EXECUTABLE)
image/stock_icons/svg-to-png.sh
packaging/appimage/AppRun
packaging/macosx/osx-app.sh.in
+ packaging/macosx/osx-dmg.sh.in
packaging/source/git-export-release.sh.in
tools/compress-pngs.sh
tools/debian-setup.sh