aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-02-10 13:48:48 -0800
committerGerald Combs <gerald@wireshark.org>2015-02-19 22:09:34 +0000
commit999bbc9b700543d92d6db7301b4893ebbcd883cc (patch)
tree0559a5fde2c19ff99473e83bd2b03aa53972fbac /CMakeLists.txt
parentc200f1e90bf75d5f15046d97657dafd4127ad278 (diff)
Qt: Add more version and packaging information to the main window.
Add a "flavor" (for lack of a better word) banner, which can be set at build time via WIRESHARK_VERSION_FLAVOR / VERSION_FLAVOR. Set it to "Development Build" by default. This effectively migrates the "DEVELOPMENT VERSION" logo image text from the GTK+ UI. Add full release and automatic update information at the bottom. Remove the short version from the welcome banner (top left). To do: - Add back support for gui_version_placement. - Move the version and repository branch to the flavor label? - Add update links as appropriate to the bottom. - Clean up layout and spacing. Change-Id: I28af33e6c2beb855f803a2dfedef49f3e8389057 Reviewed-on: https://code.wireshark.org/review/7071 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf5c017f10..2f0eaa790d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,6 +98,13 @@ set(PROJECT_PATCH_VERSION 3)
set(PROJECT_VERSION_EXTENSION "$ENV{WIRESHARK_VERSION_EXTRA}")
set(PROJECT_VERSION ${PROJECT_MAJOR_VERSION}.${PROJECT_MINOR_VERSION}.${PROJECT_PATCH_VERSION}${PROJECT_VERSION_EXTENSION})
+# Banner shown at top right of Qt welcome screen.
+if(DEFINED ENV{WIRESHARK_VERSION_FLAVOR})
+ set(VERSION_FLAVOR "$ENV{WIRESHARK_VERSION_FLAVOR}")
+else()
+ set(VERSION_FLAVOR "Development Build")
+endif()
+
# These are required in .rc files and manifests
set(VERSION_MAJOR ${PROJECT_MAJOR_VERSION})
set(VERSION_MINOR ${PROJECT_MINOR_VERSION})