aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-10 23:08:14 +0100
committerJoão Valverde <j@v6e.pt>2017-09-17 16:55:51 +0000
commit9260461f4fcc78ed7d4ac9936508dcd57ed40e6b (patch)
tree01eb87c39a3cf09401986fa5ad803e5307849091 /CMakeLists.txt
parent978f6b4e1a94c831fa90421b6127e14f6ec9de17 (diff)
plugins: Use minor version number for plugin install path
Wireshark patch releases (X.Y.Z) are binary compatible so reflect that in the plugin installation path. By installing to $pkglibdir/plugins/X.Y out-of-tree plugins don't need to be reinstalled with every patch release. Change-Id: I9d1728e6fb12bcb51d2a723af22c750cb7a966cf Reviewed-on: https://code.wireshark.org/review/23497 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29e5b37081..8350203bbb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1360,7 +1360,7 @@ if(LIBSSH_FOUND)
endif()
# Directory where plugins and Lua dissectors can be found.
-set(PLUGIN_VERSION_DIR "plugins/${CPACK_PACKAGE_VERSION}")
+set(PLUGIN_VERSION_DIR "plugins/${PROJECT_MAJOR_VERSION}.${PROJECT_MINOR_VERSION}")
set(PLUGIN_INSTALL_LIBDIR "${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/${PLUGIN_VERSION_DIR}")
# Used by the WiresharkConfig.cmake.in module
if (WIN32)