aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-11 15:14:01 +0100
committerJoão Valverde <j@v6e.pt>2017-09-11 19:11:50 +0000
commit83aabe5500fda8fda8a5eb09982361f0df860e6f (patch)
treee0fff31824464f451fbbe3c91eff12b7309da04f /CMakeLists.txt
parentc4528780732825267d2eebac4827625f39e33e5d (diff)
CMake: Fix RPATH after ga338f87f33
GNUInstallDirs uses lib64 on x86_64. Change-Id: I4e124a6b501bf2166e7270abbff53d52c9115f45 Reviewed-on: https://code.wireshark.org/review/23496 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7bd2f4a2eb..24f5059afa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,9 +202,9 @@ include(GNUInstallDirs)
# a non-default directory on Unix-like systems other than macOS.
# https://cmake.org/Wiki/CMake_RPATH_handling
if(NOT CMAKE_INSTALL_RPATH AND NOT (WIN32 OR APPLE))
- LIST(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_PREFIX}/lib" IS_SYSTEM_DIR)
+ LIST(FIND CMAKE_C_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_FULL_LIBDIR}" IS_SYSTEM_DIR)
if("${IS_SYSTEM_DIR}" STREQUAL "-1")
- SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+ SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}")
SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
endif("${IS_SYSTEM_DIR}" STREQUAL "-1")
endif()