aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-04-23 12:15:02 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2015-04-23 12:49:22 +0000
commit7d6a1e7da2629757c7dac57b5df6661b4fd61e6a (patch)
treec0048d77e4ea4dd4b1242bacd62ae0e6716644a3 /CMakeLists.txt
parent2665578aba714a7fc34a1ddca67317ce01bf88c9 (diff)
CMake fix windows setup
Standardise the args to win-setup.ps1 Change-Id: Ibd9d7bb338edb1cef444abc37a7b103eec38fb09 Reviewed-on: https://code.wireshark.org/review/8173 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c752f518f..7a9c259659 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,18 +84,18 @@ if(WIN32)
file (TO_NATIVE_PATH ${CMAKE_SOURCE_DIR}/tools/win-setup.ps1 _win_setup)
file (TO_NATIVE_PATH "$ENV{WIRESHARK_BASE_DIR}/wireshark-${WIRESHARK_TARGET_PLATFORM}-libs" _ws_lib_dir)
if(MSVC12)
- set(_vsversion_args "-VSVersion 12")
+ set(_vsversion_args "12")
elseif(MSVC11)
- set(_vsversion_args "-VSVersion 11")
+ set(_vsversion_args "11")
elseif(MSVC10)
- set(_vsversion_args "-VSVersion 10")
+ set(_vsversion_args "10")
endif()
# Is it possible to have a one-time, non-cached option in CMake? If
# so, we could add a "-DFORCE_WIN_SETUP" which passes -Force to
# win-setup.ps1.
execute_process(
- COMMAND ${POWERSHELL_COMMAND} "${_win_setup}" -Destination "${_ws_lib_dir}" -Platform ${WIRESHARK_TARGET_PLATFORM} ${_vsversion_args}
+ COMMAND ${POWERSHELL_COMMAND} "${_win_setup}" -Destination "${_ws_lib_dir}" -Platform ${WIRESHARK_TARGET_PLATFORM} -VSVersion ${_vsversion_args}
RESULT_VARIABLE _win_setup_failed
)
if (${_win_setup_failed})