aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2011-11-07 23:42:53 +0000
committerGerald Combs <gerald@wireshark.org>2011-11-07 23:42:53 +0000
commit7d442f4c22c58a970a6d00c2affac1659cdb81f6 (patch)
tree560cbb5c5df3cf623f7d3e0eb792ec9202a0e8a8 /CMakeLists.txt
parent60247a582b5852d7c84f500051d479893d8dc0c6 (diff)
Change the use of threads from "mostly always, depending on your
configure options and Gtk+ and GLib versions" to "always". svn path=/trunk/; revision=39751
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85cb6ca7b4..153d304183 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -227,9 +227,10 @@ endif()
# - set HAVE_XXX
#The minimum package list
-set(PACKAGELIST GLIB2 GMODULE2 M LEX YACC Perl SH PythonInterp)
+set(PACKAGELIST GLIB2 GMODULE2 GTHREAD2 M LEX YACC Perl SH PythonInterp)
set(GLIB2_FIND_REQUIRED)
set(GLIB2_MIN_VERSION 2.14.0)
+set(GTHREAD2_REQUIRED)
set(PCAP_REQUIRED)
set(M_REQUIRED)
@@ -249,14 +250,6 @@ if(BUILD_wireshark)
set(GTK2_FIND_VERSION 2.12)
set(GTK2_DEBUG false)
endif()
- if(ENABLE_THREADS)
- set(PACKAGELIST ${PACKAGELIST} GTHREAD2)
- endif()
-endif()
-
-if(BUILD_dumpcap)
- set(PACKAGELIST ${PACKAGELIST} GTHREAD2)
- set(GHTREAD2_REQUIRED)
endif()
# SMI SNMP