aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-11-15 13:30:19 -0800
committerGerald Combs <gerald@wireshark.org>2019-11-15 22:34:06 +0000
commit7cc5f4c45f9792f2cd3d207efed48aa021bdffd4 (patch)
treed3250465db3a3b75708859f313acbcfa9aecd63a /CMakeLists.txt
parente624545b957ad3b6780088e37ddda872e1b23735 (diff)
CMake: Work correctly without Sparkle.
Set or clear SPARKLE_LIBRARIES and SPARKLE_INCLUDE_DIRS in FindSparkle.cmake, similar to what we do in other modules. Use them instead of SPARKLE_LIBRARY and SPARKLE_INCLUDE_DIR. Change-Id: I023c711edd6a44421aadf85413da3207d9b08e64 Reviewed-on: https://code.wireshark.org/review/35097 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 959dee687d..2d0d24f2e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2271,7 +2271,7 @@ if(BUILD_wireshark AND QT_FOUND)
${APPLE_APPKIT_LIBRARY}
${APPLE_CORE_FOUNDATION_LIBRARY}
${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
- ${SPARKLE_LIBRARY}
+ ${SPARKLE_LIBRARIES}
${WIN_WS2_32_LIBRARY}
${WIN_VERSION_LIBRARY}
${WINSPARKLE_LIBRARIES}
@@ -2318,7 +2318,7 @@ if(BUILD_wireshark AND QT_FOUND)
endif()
target_link_libraries(wireshark ${wireshark_LIBS})
- target_include_directories(wireshark SYSTEM PRIVATE ${SPARKLE_INCLUDE_DIR})
+ target_include_directories(wireshark SYSTEM PRIVATE ${SPARKLE_INCLUDE_DIRS})
install(
TARGETS wireshark