aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2020-01-06 09:58:38 -0800
committerGerald Combs <gerald@wireshark.org>2020-01-06 19:50:50 +0000
commit7a09c78f123b5dd1237000726f19e2801edeaf39 (patch)
treef22a656841a463d52039b352380f5261031d57e9 /CMakeLists.txt
parent05d772ce7b40008dcb99f492aece86507166c233 (diff)
NSIS: Don't package .pdb files.
We run `windeployqt ... --pdbs` at build time, which means that we need to be careful not to include them in the NSIS package. Switch from using wildcards ("File ...\*") to using separate "File" commands for each file. Simplify the PDB Zip package command while we're here. Bug: 16307 Change-Id: Ibd9bcbdfdc216f1f6a067baf711bbc184845143f Reviewed-on: https://code.wireshark.org/review/35670 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 301fe24af0..799b7150ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1954,10 +1954,8 @@ if(WIN32)
add_custom_command(TARGET pdb_zip_package POST_BUILD
COMMAND ${CMAKE_COMMAND} -E remove -f "${_pdb_zip}"
COMMAND ${ZIP_EXECUTABLE} a -tzip -mmt=on "${_pdb_zip_win}"
- *.pdb *.lib
- extcap/*.pdb
- ${PLUGIN_VERSION_DIR}/epan/*.pdb
- ${PLUGIN_VERSION_DIR}/wiretap/*.pdb
+ -bb2
+ -r *.pdb *.lib
WORKING_DIRECTORY "${_dll_output_dir}"
)
endif()