aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2010-05-19 13:05:35 +0000
committerJörg Mayer <jmayer@loplof.de>2010-05-19 13:05:35 +0000
commit76cee2c2a1cceec6d55ddb44f83a7858ea8c81db (patch)
tree95eeb233f20c0f18496e41d4a0341c3c84b3124d /CMakeLists.txt
parent10fb76ce44005721ccedd2c3e1aa4a3b5be8071a (diff)
Commit 32350 replaced the self written FindZ.cmake by cmakes
FindZLIB.cmake. What it didn't do was do adapt the magic names that are derived from the name of the FindXXX.cmake script. Fix that. Also add $Id$ to the FindZLIB.cmake script. svn path=/trunk/; revision=32899
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbef7412cf..ceb0e49cf5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -330,6 +330,10 @@ endif()
if(ENABLE_AIRPCAP)
set(HAVE_AIRPCAP 1)
endif()
+# That's the name autofoo uses
+if(HAVE_LIBZLIB)
+ set(HAVE_LIBZ 1)
+endif()
include(ConfigureChecks.cmake)
@@ -588,7 +592,7 @@ set(LIBEPAN_LIBS
${GCRYPT_LIBRARIES}
${GNUTLS_LIBRARIES}
${SMI_LIBRARIES}
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
${M_LIBRARIES}
)
@@ -689,7 +693,7 @@ if(BUILD_randpkt)
# @NSL_LIBS@
${CARES_LIBRARIES}
${ADNS_LIBRARIES}
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
)
set(randpkt_FILES
randpkt.c
@@ -704,7 +708,7 @@ if(BUILD_text2pcap)
set(text2pcap_LIBS
wiretap
${M_LIBRARIES}
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
)
set(text2pcap_CLEAN_FILES
text2pcap.c
@@ -725,7 +729,7 @@ endif()
if(BUILD_mergecap)
set(mergecap_LIBS
wiretap
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
)
set(mergecap_FILES
mergecap.c
@@ -742,7 +746,7 @@ endif()
if(BUILD_capinfos)
set(capinfos_LIBS
wiretap
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
${GCRYPT_LIBRARIES}
${APPLE_COCOA_LIBRARY}
)
@@ -759,7 +763,7 @@ endif()
if(BUILD_editcap)
set(editcap_LIBS
wiretap
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
)
set(editcap_FILES
editcap.c
@@ -784,7 +788,7 @@ if(BUILD_dumpcap)
# @NSL_LIBS@
${GCRYPT_LIBRARIES}
${GNUTLS_LIBRARIES}
- ${Z_LIBRARIES}
+ ${ZLIB_LIBRARIES}
${APPLE_COCOA_LIBRARY}
)
set(dumpcap_FILES