aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-08-17 14:38:54 -0700
committerGuy Harris <guy@alum.mit.edu>2017-08-17 21:39:57 +0000
commit6e6bcacb72db2db6baada7b00924c96ff05c5ca2 (patch)
tree8638e15833052525b52f02f6bd1f46949069c38c /CMakeLists.txt
parent1e659474c93d48e07e3908814bd423c228d38f2f (diff)
Fix some comments.
"The release mode (CMAKE_BUILD_TYPE=release) defines NDEBUG" isn't Linux-specific; it's true in the Unix Makefile generator, and possibly in other generators. (The Visual Studio generator, at least for newer versions of VS, lets you specify at *build* time what type of build to do, so the generated build files don't unconditionally define, or not define, NDEBUG, they do so based on the build type.) The RPATH stuff is done on Unix-like systems *except* for macOS. Change-Id: Ieffbaaa9a8e11a1a30b34036a2412c6735baa0c8 Reviewed-on: https://code.wireshark.org/review/23114 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8f3d1df13..82c77d3c24 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,11 +182,15 @@ if(NOT LIBRARY_OUTPUT_PATH)
"Single output directory for building all libraries.")
endif()
-# Under Linux the release mode (CMAKE_BUILD_TYPE=release) defines NDEBUG
+#
+# The release mode (CMAKE_BUILD_TYPE=release) defines NDEBUG for
+# the Unix Makefile generator.
+#
+
#Defines CMAKE_INSTALL_BINDIR, CMAKE_INSTALL_DATADIR, etc ...
include(CMakeInstallDirs)
# Make sure our executables can can load our libraries if we install into
-# a non-default directory on UNIX/Linux.
+# a non-default directory on Unix-like systems other than macOS.
# https://cmake.org/Wiki/CMake_RPATH_handling
if(NOT CMAKE_INSTALL_RPATH AND NOT (WIN32 OR APPLE))
LIST(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_PREFIX}/lib" IS_SYSTEM_DIR)