aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-22 06:21:53 +0000
committerJoão Valverde <j@v6e.pt>2016-03-01 19:23:39 +0000
commit6b54fbf3bfb7a3b0519637d01fa36bba8cec9c98 (patch)
treeeb9ce7199c857fe314da04cabd448e9381e451ac /CMakeLists.txt
parent5da2b437035dbd478293caa1c9242fe2e37924e6 (diff)
CMake: Add more structure to libwireshark build
Smaller epan/CMakeLists.txt is easier to work with and this structure is well suited to CMake. It should make it easier to manage and configure each epan module differently if necessary. Change-Id: Ia649db3b7dcd405aa43dbdba3288699d5e375229 Reviewed-on: https://code.wireshark.org/review/14068 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11744f5d9c..6b6c1783dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ if(WIN32)
# 3.1.3 is the currently supported version
cmake_minimum_required(VERSION 3.1.3)
else()
- cmake_minimum_required(VERSION 2.8.3)
+ cmake_minimum_required(VERSION 2.8.8)
endif()
# Needs to be set after cmake_minimum_required or cmake_policy(VERSION)