aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-01-06 10:48:53 -0800
committerGerald Combs <gerald@wireshark.org>2016-02-02 00:27:42 +0000
commit5cad2cd09b2e1612c0e14ee3cc28bcaed19cf6f0 (patch)
tree606f1f996c186af05c9c3e92077d1c52f05d803d /CMakeLists.txt
parent8294e773b0d8b8d0cc0cb3da104fb4c621b4a3ae (diff)
Add configure-time synchronous DNS warnings.
In CMake and Autotools, warn the user when neither c-ares nor ADNS is present. Note that we might want to make asynchronous DNS a requirement. Change-Id: Ia9cce56cc2286cdc72303fc1410f899f9c320d84 Reviewed-on: https://code.wireshark.org/review/13080 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90fde1e1a2..1c7589dd20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -885,6 +885,11 @@ endif()
if(HAVE_LIBADNS)
set(HAVE_GNU_ADNS 1)
endif()
+if(NOT HAVE_LIBCARES AND NOT HAVE_LIBADNS)
+ # We should make this an error at some point.
+ message(WARNING "Not using c-ares or ADNS.")
+ message(WARNING "Synchronous name resolution can seriously degrade performance.")
+endif()
if(HAVE_LIBNL AND HAVE_AIRPCAP)
message(ERROR "Airpcap and Libnl support are mutually exclusive")
endif()