aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2018-03-03 17:55:36 +0000
committerAnders Broman <a.broman58@gmail.com>2018-03-04 08:58:07 +0000
commit5b079291c41ae4f8abe7a33fa7b886ae0a314a30 (patch)
treefd465bec3856addb5730c6f994614e2117cb5b8c /CMakeLists.txt
parentc37eeafe8100624fb0c315ac607db32f7ad2c941 (diff)
Windows: Remove support for MSVC older than VS2015
Cleanup the support for older versions of Visual Studio Change-Id: Ieb97d56e9bff6a5902433e8d99b27276bc7034f7 Reviewed-on: https://code.wireshark.org/review/26247 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00f3efdbb9..747223adf6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -288,21 +288,12 @@ endif()
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
- if (MSVC10)
- set(MSC_VER_REQUIRED 1600)
- elseif(MSVC11)
- set(MSC_VER_REQUIRED 1700)
- elseif(MSVC12)
- set(MSC_VER_REQUIRED 1800)
- elseif(MSVC14)
- set(MSC_VER_REQUIRED 1900)
- else()
+ if ((MSVC_VERSION LESS "1900") OR (MSVC_VERSION GREATER_EQUAL "2000"))
message(FATAL_ERROR "You are using an unsupported version of MSVC")
endif()
add_definitions(
/DWIN32_LEAN_AND_MEAN
- "/DMSC_VER_REQUIRED=${MSC_VER_REQUIRED}"
/D_CRT_SECURE_NO_DEPRECATE
# NOMINMAX keeps windows.h from defining "min" and "max" via windef.h.
# This avoids conflicts with the C++ standard library.