aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2006-09-05 09:27:22 +0000
committerJörg Mayer <jmayer@loplof.de>2006-09-05 09:27:22 +0000
commit57656db02efe1798883c9a40b04311133e64e626 (patch)
treee738bcbdca2e392d180e71874d375f65d8938eaf /CMakeLists.txt
parent72651ba02d94c02c4bbef793c587bb9bcf2790c9 (diff)
OK, as I haven't had any negative feedback, I'm adding my work
to use cmake as a build system. It's in no way complete, I'd just like others to be able to participate in playing with cmake and to document what I'm doing. Please read the README.cmake for what can be done right now. svn path=/trunk/; revision=19149
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000000..34c8086ab0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,51 @@
+PROJECT(dumpcap C)
+
+SET(dumpcap_LIBS wiretap)
+
+SET(CMAKE_VERBOSE_MAKEFILE ON)
+SET(BUILD_SHARED_LIBS ON)
+SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
+
+SET(PLATFORM_SRC
+ capture-pcap-util-unix.c
+)
+
+SET(dumpcap_FILES
+ capture_opts.c
+ capture_loop.c
+ capture-pcap-util.c
+ capture_stop_conditions.c
+ clopts_common.c
+ conditions.c
+ dumpcap.c
+ pcapio.c
+ ringbuffer.c
+ sync_pipe_write.c
+ tempfile.c
+ version_info.c
+
+ ${PLATFORM_SRC}
+)
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR} ${CMAKE_SOURCE_DIR}/wiretap)
+
+ADD_DEFINITIONS(-DHAVE_CONFIG_H -D_U_=\"__attribute__\(\(unused\)\)\")
+
+LINK_DIRECTORIES(wiretap)
+
+ADD_EXECUTABLE(dumpcap ${dumpcap_FILES})
+
+FIND_PACKAGE(GTK2)
+INCLUDE_DIRECTORIES(${GTK2_INCLUDE_DIR})
+SET(dumpcap_LIBS ${dumpcap_LIBS} ${GTK2_LIBRARIES})
+
+FIND_PACKAGE(ZLIB)
+INCLUDE_DIRECTORIES(${ZLIB_INCLUDE_DIR})
+SET(dumpcap_LIBS ${dumpcap_LIBS} ${ZLIB_LIBRARIES})
+
+FIND_PACKAGE(Pcap)
+INCLUDE_DIRECTORIES(${PCAP_INCLUDE_DIR})
+SET(dumpcap_LIBS ${dumpcap_LIBS} ${PCAP_LIBRARIES})
+
+TARGET_LINK_LIBRARIES(dumpcap ${dumpcap_LIBS})
+