aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2018-04-09 12:31:38 +0200
committerDario Lombardo <lomato@gmail.com>2018-04-18 08:57:39 +0000
commit511c2e166a6d3eeb37930a3dd7f40056498456ca (patch)
treeda9d1f74320c65560a2eb4517c9fe78b5a5d886b /CMakeLists.txt
parent88435354c024597601bdbf2cb916f4b07faf2e52 (diff)
tshark: add -G elastic-mapping report.
This option generates an ElasticSearch mapping file as described here: https://www.elastic.co/blog/analyzing-network-packets-with-wireshark-elasticsearch-and-kibana It leverages the Glib-json library. Change-Id: Iff25f991e87d3da07bf06654e353fb785799dde9 Reviewed-on: https://code.wireshark.org/review/26848 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 492cd9fff7..4337b8a2fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -894,6 +894,8 @@ endif()
set(PACKAGELIST ${PACKAGELIST} LIBSSH)
set(LIBSSH_OPTIONS "0.6")
+set(PACKAGELIST ${PACKAGELIST} JSONGLIB)
+
if(ENABLE_PCAP)
set(PACKAGELIST ${PACKAGELIST} PCAP)
endif()
@@ -1129,6 +1131,9 @@ endif()
if(LIBSSH_FOUND)
set(HAVE_LIBSSH 1)
endif()
+if(JSONGLIB_FOUND)
+ set(HAVE_JSONGLIB 1)
+endif()
if(NGHTTP2_FOUND)
set(HAVE_NGHTTP2 1)
endif()
@@ -1679,6 +1684,11 @@ set(LIBEPAN_LIBS
${WINSPARKLE_LIBRARIES}
)
+if(JSONGLIB_FOUND)
+ list(APPEND LIBEPAN_LIBS ${JSONGLIB_LIBRARIES})
+endif()
+
+
if(WIN32)
set(_dll_output_dir "${DATAFILE_DIR}")
add_custom_target(copy_cli_dlls)
@@ -1717,6 +1727,9 @@ if(WIN32)
if (LIBSSH_FOUND)
list (APPEND OPTIONAL_DLLS "${LIBSSH_DLL_DIR}/${LIBSSH_DLL}")
endif(LIBSSH_FOUND)
+ if (JSONGLIB_FOUND)
+ list (APPEND OPTIONAL_DLLS "${JSONGLIB_DLL_DIR}/${JSONGLIB_DLL}")
+ endif(JSONGLIB_FOUND)
foreach( _dll ${GCRYPT_DLLS} )
list (APPEND OPTIONAL_DLLS "${GCRYPT_DLL_DIR}/${_dll}")
endforeach(_dll)
@@ -2346,6 +2359,7 @@ if(BUILD_tshark)
${SHARK_COMMON_SRC}
${CMAKE_BINARY_DIR}/image/tshark.rc
)
+
add_executable(tshark ${tshark_FILES})
add_dependencies(tshark version)
set_extra_executable_properties(tshark "Executables")