aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Huus <eapache@gmail.com>2015-11-04 14:11:49 -0500
committerEvan Huus <eapache@gmail.com>2015-11-06 04:40:42 +0000
commit4f01f3d8062fff370a3fcf35ebf7c19d3642417b (patch)
treec0a23c78714b41090ba1b370977fcced103685a5 /CMakeLists.txt
parent8fb1f8e55272fca7a3d98356d5d0a58ece7d186e (diff)
Move -fno-delete-null-pointer-checks to optional
It is no longer supported on El Capitan's clang, which was causing my cmake/osx/qt build to fail with: clang: error: optimization flag '-fno-delete-null-pointer-checks' is not supported Change-Id: Idfac336758cdea9a34446d8281cd237ad3ee6823 Reviewed-on: https://code.wireshark.org/review/11571 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6d06c10c23..dc71c0fb2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -355,7 +355,6 @@ else()
-Wformat-security
-fwrapv
-fno-strict-overflow
- -fno-delete-null-pointer-checks
-Wvla
-Waddress
-Wattributes
@@ -432,6 +431,10 @@ else()
# (about glib library not using Doxygen)
#
-Wdocumentation
+ #
+ # No longer supported by El Capitan clang on C++
+ #
+ -fno-delete-null-pointer-checks
)
set(WIRESHARK_EXTRA_COMPILER_C_ONLY_FLAGS