aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-08-06 18:20:40 -0700
committerGuy Harris <guy@alum.mit.edu>2017-08-07 01:23:07 +0000
commit4dc835c9c6b7af68cd63ae9efa26ac23ee3d9365 (patch)
tree092c11bc1d67df466871ff3aae9cf39f8cbb632f /CMakeLists.txt
parent98ff0410c83ae9868803bb81319a3476dfb2c8f1 (diff)
-Wcast-align will warn about legitimate code.
Maybe there's some way to say "yes, I know that the pointer being cast is appropriately aligned", or maybe some platforms say "yes, I know, this is a struct sockaddr *, but those are aligned well enough for any other socket address types", in which case we might be able to turn that on by default in some cases. Change-Id: I6b8cff7ebfe27785b20adbbc2f855e859b090236 Reviewed-on: https://code.wireshark.org/review/22983 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40877aa581..aa8e74871e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -557,7 +557,10 @@ else()
-Wmissing-declarations
#
# A bunch of "that might not work on SPARC" code blocks
- # this one for now.
+ # this one for now; some of it is code that *will* work
+ # on SPARC, such as casts of "struct sockaddr *" to
+ # "struct sockaddr_in *", which are required by some
+ # APIs such as getifaddrs().
#
-Wcast-align
#