aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-10-10 21:57:03 -0700
committerGuy Harris <guy@alum.mit.edu>2015-10-11 04:59:07 +0000
commit3d9f0db88a251d4363987d523510770ee315b4b9 (patch)
tree5910b811a51022e9829994cdcb9a162cc4dd594f /CMakeLists.txt
parent69a70df0a0fa0d9953a66222006a45af5572ff04 (diff)
Temporarily make cmake builds verbose, for debugging purposes.
Try to figure out why CMake builds work on the 32-bit OS X buildbot but autotools builds don't; either the compiler commands are different in ways that break the autotools build, or the config.h files are different in ways that break the autotools build, or magic pixies affect the builds in different ways that only break the autotools build. Change-Id: Id24bad04ff8ef755e4966e28fd445c2ab05c6913 Reviewed-on: https://code.wireshark.org/review/10931 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79db608efe..099de1c815 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,13 @@
project(Wireshark C CXX)
+#
+# XXX - temporary, to debug a weird build problem where the build
+# works with CMake but fails with autotools; do this verbosely
+# so that the compile commands can be seen for both builds.
+#
+set(CMAKE_VERBOSE_MAKEFILE 1)
+
message(STATUS "Generating build using CMake ${CMAKE_VERSION}")
if(WIN32)
# Needed for proper Qt linking. See