aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2016-01-26 17:12:53 -0800
committerGuy Harris <guy@alum.mit.edu>2016-01-27 01:13:36 +0000
commit3cecda0246894b0f2be8cbf689b7cebb0f74e1e8 (patch)
tree4416c5ce07c408aef08217b6cc10f6a8c9a092c5 /CMakeLists.txt
parentdc91ac5241f89f764fc442f9f8b6245ce308dd2d (diff)
Explain why we're still checking for MSVC.
Change-Id: I7d656eb5b38e8f7697b1414b6b3364a85ad132cf Reviewed-on: https://code.wireshark.org/review/13557 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5390ba84ee..137d52a670 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -595,7 +595,16 @@ else()
set (C_UNUSED "" )
endif()
-
+#
+# XXX - at least with the Visual Studio 12 generator, this would test
+# whether the flag works with the compiler, but, at least when building
+# for Win64, the flag "works", in that the link succeeds, but with a
+# warning of an unused linker argument.
+#
+# So we leave it out for now; maybe there's a way to force the linker to
+# fail with unknown arguments, or maybe we have to look for error
+# messages in the linker output, the way CHECK_C_COMPILER_FLAG does.
+#
if(NOT CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(WIRESHARK_LD_FLAGS
-Wl,--as-needed