aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-07-15 23:46:51 +0000
committerGuy Harris <guy@alum.mit.edu>2015-07-15 23:46:58 +0000
commit2e215db532f408697ba16f2d83524a64cc9e6424 (patch)
treee0fc85aafed57513b233b3c2b1681376f1c5437e /CMakeLists.txt
parent5523726e6960fe9d7e301376fd7a94599f65fd42 (diff)
Revert "On OS X, add the Qt -Wl,-rpath hack in CMake, as we do with autotools."
This reverts commit 4a39706272a59d43530e038f8b20436e2c3052ce. At least in one quick check, CMake 2.8.12.2 added that already with Qt 5.5.0. Change-Id: Iabf0e4aa0aa34b380f981f7d039fb3d95847041e Reviewed-on: https://code.wireshark.org/review/9654 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 1 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6fa7fc839d..8b4f912fd3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1715,23 +1715,7 @@ if(BUILD_wireshark AND QT_FOUND)
execute_process(COMMAND chmod a+x ${CMAKE_BINARY_DIR}/run/wireshark)
endif()
- if(APPLE)
- #
- # On Darwin, find where the Qt frameworks are
- # located, and add that to the rpath, just in
- # case this is Qt 5.5 or later and the frameworks
- # have an install name that begins with @rpath
- # and aren't installed in a frameworks directory
- # that's searched by default.
- #
- # It would be *amazingly convenient* if we
- # could get that from Qt's CMake configuration
- # files, but we can't, so we have to extract it from
- # an internal variable.
- #
- set(wireshark_rpath_flag "-Wl,-rpath,${_qt5Core_install_prefix}/lib")
- endif(APPLE)
- target_link_libraries(wireshark ${wireshark_rpath_flag} ${wireshark_LIBS})
+ target_link_libraries(wireshark ${wireshark_LIBS})
install(
TARGETS wireshark
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}