aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-08-07 18:35:36 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-08-07 18:35:36 +0000
commitf243c18d0afea73ac5ce95f43fb2d5f5e34a4a93 (patch)
treee4b56960256588b3dcbdbbc4e32751210b3a09bc /CMakeLists.txt
parent2c1dea27da0f6c6ce15647854e92e7ad4372a8c3 (diff)
mate_grammar.lemon:
- Fix a bug my previous patch introduced. mate/: - Unset G_DISABLE_DEPRECATED for the mate files. CMakeLists.txt configure.in: - Build with -DG_DISABLE_DEPRECATED so further usage of deprecated glib functions will be detected. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@38393 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e8329825c..32051badfd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,9 +27,11 @@ cmake_minimum_required(VERSION 2.6)
set(CMAKE_BACKWARDS_COMPATIBILITY 2.6)
# Needs to be set after cmake_minimum_required or cmake_policy(VERSION)
-#if(COMMAND cmake_policy)
+if(COMMAND cmake_policy)
+ # Backward compatibility for versions < 2.6.3
+ cmake_policy(SET CMP0011 OLD)
# cmake_policy(SET CMP0015 NEW)
-#endif(COMMAND cmake_policy)
+endif(COMMAND cmake_policy)
# set(PROJECT_VERSION "1.3.4-rc5")
# set(PROJECT_VERSION "1.3.4rc5")
@@ -158,6 +160,7 @@ endif()
add_definitions(
-DHAVE_CONFIG_H
+ -DG_DISABLE_DEPRECATED
)
# Counterhack to work around some cache magic in CHECK_C_SOURCE_COMPILES