aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-24 20:41:34 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-24 20:41:34 +0000
commitacd821a13fe9b76a7178d1644f2687c631799477 (patch)
treec6918a98de58abd1144cd9002f1a4c3c43dc815c /CMakeLists.txt
parent41bcd25194a0928d9312f84d53834aa0fe1a2d92 (diff)
Plugins are not shared libraries, so:
1) don't set thei SOVERSION - run-time-loaded modules don't have an SOVERSION; 2) build them with link mode MODULE, not SHARED, on all platforms. (Fixing 1) also fixes the problem with building them as MODULE on OS X.) git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@34243 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14216da406..6c25fbffef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -210,11 +210,7 @@ if(ENABLE_STATIC)
set(LINK_MODE_MODULE STATIC)
else()
set(LINK_MODE_LIB SHARED)
- if(APPLE)
- set(LINK_MODE_MODULE SHARED)
- else()
- set(LINK_MODE_MODULE MODULE)
- endif()
+ set(LINK_MODE_MODULE SHARED)
endif()
# The packagelist is doing some magic: If we add XXX to the packagelist, we