aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-23 07:02:33 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2010-09-23 07:02:33 +0000
commit8af47c7c37a360105496db755e93b30d7630fcb4 (patch)
tree538aef8bdf5d1bf6926857f58e1bbd2dbd6f0ec1 /CMakeLists.txt
parente65f9624a51a9fd97e08fc57dd39d1d34c1a3e9a (diff)
H. Sivank <hsivank@gmail.com>
I try to configure Wireshark with cmake on macosx 10.6. It fails with : set_target_properties called with incorrect number of arguments. Attached a patch to fix this issue. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@34201 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10cc896414..3516a50821 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -640,7 +640,7 @@ if(BUILD_wireshark)
)
add_executable(wireshark ${wireshark_FILES})
add_dependencies(wireshark svnversion)
- set_target_properties(wireshark PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(wireshark PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(wireshark ${wireshark_LIBS})
install(TARGETS wireshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -662,7 +662,7 @@ if(BUILD_tshark)
)
add_executable(tshark ${tshark_FILES})
add_dependencies(tshark svnversion)
- set_target_properties(tshark PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(tshark PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(tshark ${tshark_LIBS})
install(TARGETS tshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -678,7 +678,7 @@ if(BUILD_rawshark)
)
add_executable(rawshark ${rawshark_FILES})
add_dependencies(rawshark svnversion)
- set_target_properties(rawshark PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(rawshark PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(rawshark ${rawshark_LIBS})
install(TARGETS rawshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -692,7 +692,7 @@ if(BUILD_dftest)
util.c
)
add_executable(dftest ${dftest_FILES})
- set_target_properties(dftest PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(dftest PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(dftest ${dftest_LIBS})
install(TARGETS dftest RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -712,7 +712,7 @@ if(BUILD_randpkt)
randpkt.c
)
add_executable(randpkt ${randpkt_FILES})
- set_target_properties(randpkt PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(randpkt PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(randpkt ${randpkt_LIBS})
install(TARGETS randpkt RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -734,7 +734,7 @@ if(BUILD_text2pcap)
)
add_executable(text2pcap ${text2pcap_FILES})
add_dependencies(text2pcap svnversion)
- set_target_properties(text2pcap PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(text2pcap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(text2pcap ${text2pcap_LIBS})
install(TARGETS text2pcap RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -751,7 +751,7 @@ if(BUILD_mergecap)
)
add_executable(mergecap ${mergecap_FILES})
add_dependencies(mergecap svnversion)
- set_target_properties(mergecap PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(mergecap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(mergecap ${mergecap_LIBS})
install(TARGETS mergecap RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -769,7 +769,7 @@ if(BUILD_capinfos)
)
add_executable(capinfos ${capinfos_FILES})
add_dependencies(capinfos svnversion)
- set_target_properties(capinfos PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(capinfos PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(capinfos ${capinfos_LIBS})
install(TARGETS capinfos RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -787,7 +787,7 @@ if(BUILD_editcap)
)
add_executable(editcap ${editcap_FILES})
add_dependencies(editcap svnversion)
- set_target_properties(editcap PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(editcap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(editcap ${editcap_LIBS})
install(TARGETS editcap RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
@@ -820,7 +820,7 @@ if(BUILD_dumpcap)
)
add_executable(dumpcap ${dumpcap_FILES})
add_dependencies(dumpcap svnversion)
- set_target_properties(dumpcap PROPERTIES LINK_FLAGS ${WS_LINK_FLAGS})
+ set_target_properties(dumpcap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(dumpcap ${dumpcap_LIBS})
install(TARGETS dumpcap RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()