aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-06-08 18:10:03 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-06-08 18:10:03 +0000
commit821aa2917fc97e8240d3d8ba8a6bac8fd3299ba0 (patch)
tree7e5b98a2aa79dce57fde0110f71b46f38b43df8f /CMakeLists.txt
parent1ff5d3f7f18c17fefc5a78aa103ad8277cddbb06 (diff)
Add GTK3 cmake options. It doesn't build, just like its configure pendant.
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@37623 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7a282c935..d795c6d181 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -235,9 +235,14 @@ set(PACKAGELIST ${PACKAGELIST} HtmlViewer)
#Build the gui ?
if(BUILD_wireshark)
- set(PACKAGELIST ${PACKAGELIST} GTK2)
- set(GTK2_OPTIONS COMPONENTS gtk)
- set(GTK2_DEBUG false)
+ if(ENABLE_GTK3)
+ set(PACKAGELIST ${PACKAGELIST} GTK3)
+ set(UI_MANAGER ON)
+ else()
+ set(PACKAGELIST ${PACKAGELIST} GTK2)
+ set(GTK2_OPTIONS COMPONENTS gtk)
+ set(GTK2_DEBUG false)
+ endif()
endif()
if(BUILD_dumpcap)
@@ -361,6 +366,10 @@ endif()
if(ENABLE_AIRPCAP)
set(HAVE_AIRPCAP 1)
endif()
+# No matter which version of GTK is present
+if(GTK2_FOUND OR GTK3_FOUND)
+ set(GTK_FOUND ON)
+endif()
# That's the name autofoo uses
if(HAVE_LIBZLIB)
set(HAVE_LIBZ 1)
@@ -414,7 +423,7 @@ add_subdirectory( tools/lemon )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
-if(BUILD_wireshark AND GTK2_FOUND)
+if(BUILD_wireshark AND GTK_FOUND)
add_subdirectory( gtk )
endif()
@@ -635,10 +644,11 @@ set(LIBEPAN_LIBS
${M_LIBRARIES}
)
-if(BUILD_wireshark AND GTK2_FOUND)
+if(BUILD_wireshark AND GTK_FOUND)
set(wireshark_LIBS
ui
${GTK2_LIBRARIES}
+ ${GTK3_LIBRARIES}
codecs
${PORTAUDIO_LIBRARIES}
${LIBEPAN_LIBS}