aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-05-19 04:35:04 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2011-05-19 04:35:04 +0000
commit199dc7bed53da51e9d4dd634bd1a17e1bfcd80da (patch)
tree810afab2ecd6afe70042dc4f9e77ce9e40afb23f /CMakeLists.txt
parente1802c9fda07b10d214ceaa01ed862b8a9c0820a (diff)
Update CMakeLists to follow commit 37219.
Remove a duplicate check in configure.in git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@37277 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1364f7c562..d3c6273d41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,7 @@ set(WIRESHARK_C_FLAGS
-Warray-bounds
-Wcast-align
-Wformat-security
+ -Wold-style-definition
-fexcess-precision=fast
)
@@ -140,7 +141,10 @@ set(WIRESHARK_EXTRA_C_FLAGS
-Wjump-misses-init
# packet-ncp2222.inc prevents this from going into all warnings
-Wwrite-strings
+ # GLib blocks this for now.
-Wstrict-prototypes
+ # All the registration functions block these for now.
+ -Wmissing-prototypes
-Wmissing-declarations
# Problem with packet-afs.c
-Wshadow