aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2011-08-05 00:25:02 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2011-08-05 00:25:02 +0000
commit106f4217df8f6a019eb09676bbc1d9ad32fd780c (patch)
tree569f1348869aec0bc2c6fc2d73b07a3f48209ee1 /CMakeLists.txt
parenteaa89b5c913fb08915a56c3e6b4103aa90ed80d6 (diff)
Use GLIB2_LDFLAGS instead of GLIB2_LIBRARIES for wsutil, since it
includes the path to the libraries. Add gthread to wireshark_LIBS if threads are enabled. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@38345 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f1f9cf0e4..5a1a585d71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,6 +243,9 @@ if(BUILD_wireshark)
set(GTK2_FIND_VERSION 2.12)
set(GTK2_DEBUG false)
endif()
+ if(ENABLE_THREADS)
+ set(PACKAGELIST ${PACKAGELIST} GTHREAD2)
+ endif()
endif()
if(BUILD_dumpcap)
@@ -667,6 +670,9 @@ if(BUILD_wireshark AND GTK_FOUND)
${APPLE_CORE_SERVICES_LIBRARY}
${APPLE_COCOA_LIBRARY}
)
+ if(ENABLE_THREADS)
+ set(wireshark_LIBS ${wireshark_LIBS} ${GTHREAD2_LIBRARIES})
+ endif()
set(wireshark_FILES
airpcap_loader.c
alert_box.c