aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-26 03:16:17 +0000
committerAnders Broman <a.broman58@gmail.com>2016-04-04 06:49:55 +0000
commite005bc819c201c49cf330a2607ad0770f145904e (patch)
treeaaff654c2682c3bde08440b5d9526deee1e033c5 /CMakeLists.txt
parent1cf7834b2d16f549c6145e5d36b8b7dd7a384223 (diff)
Remove synchronous DNS name resolution
Change-Id: Ie5e670b769eb0674950f3679ef511047641c2873 Reviewed-on: https://code.wireshark.org/review/14751 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cd288e208c..118e5f97ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -879,9 +879,8 @@ if(HAVE_LIBCARES)
set(HAVE_C_ARES 1)
endif()
if(NOT HAVE_LIBCARES)
- # We should make this an error at some point.
message(WARNING "Not using c-ares.")
- message(WARNING "Synchronous name resolution can seriously degrade performance.")
+ message(WARNING "DNS name resolution for captures will be disabled.")
endif()
if(HAVE_LIBNL AND HAVE_AIRPCAP)
message(ERROR "Airpcap and Libnl support are mutually exclusive")