aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2016-03-28 22:25:56 +0200
committerJörg Mayer <jmayer@loplof.de>2016-03-28 22:45:56 +0000
commit9f40a75bbb9ea8e205bf0ebf9f0651971417cd6e (patch)
treed9ea77539b0824860ec15d99f2af06bdd239df36 /CMakeLists.txt
parente6c54017a7fbf4009454577a445530a7649f2c4f (diff)
Trun on -Wused-but-marked-unused but only as warning, never as error.
(possibly clang only) Change-Id: I014b8f069515af6128177dfc5813380db445957c Reviewed-on: https://code.wireshark.org/review/14686 Petri-Dish: Jörg Mayer <jmayer@loplof.de> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac866575b6..f5a12d998a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -348,8 +348,11 @@ else()
-Wpointer-arith
-Warray-bounds
-Wformat-security
+ -Wused-but-marked-unused
+ -Wno-error=used-but-marked-unused
-fwrapv
-fno-strict-overflow
+ # -ferror-limit=0
-Wvla
-Waddress
-Wattributes