aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2016-03-19 23:36:22 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2016-03-20 14:03:12 +0000
commit92db934c7c4473ab97883c95b920b027f89f4b8d (patch)
treef64342704d80867b8d0ae8039c51eb6712d36bf0 /CMakeLists.txt
parent9bcac48403de9aff6435d0f48028ae1f72f64528 (diff)
Fix CMake target FOLDER properties
Add FOLDER properties to targets to clean up the presentation in Visual Studio. Change-Id: I35a175175db055443572c58a069879061fdcf0a3 Reviewed-on: https://code.wireshark.org/review/14528 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69370764ed..4230191aaf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2565,6 +2565,7 @@ add_custom_target(test-sh
-P ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
DEPENDS ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
)
+set_target_properties(test-sh PROPERTIES FOLDER "Tests")
#Generate list of AUTHORS (Name + E-Mail) sort by name
if (GIT_EXECUTABLE)
@@ -2576,8 +2577,7 @@ if (GIT_EXECUTABLE)
else (GIT_EXECUTABLE)
ADD_CUSTOM_TARGET( gen-authors COMMAND ${CMAKE_COMMAND} -E echo "Git not found." )
endif (GIT_EXECUTABLE)
-
-set_target_properties(test-sh PROPERTIES FOLDER "Tests")
+set_target_properties(gen-authors PROPERTIES FOLDER "Docs")
add_custom_target(test-programs
DEPENDS test-sh