aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichaƂ Orynicz <michal.orynicz@tieto.com>2014-04-08 10:40:09 +0200
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2014-04-09 07:54:10 +0000
commit3057e309dfe260f0902a88e9049dad1b8f194538 (patch)
tree96d13339245a8240ed33a3bead99a51efb617af3 /CMakeLists.txt
parent8d9c45d965bfd20b099fdab7c617b6e3ad95b69d (diff)
Change how WERROR and WERR_UNKNOWN is turned off
Use setting WERROR and WERR_UNKNOWN explicitly to FALSE instead using unset command. This ensures that no if(WERROR) or if(WERR_UNKNOWN) clause will trigger unless these variables are set to another value. Change-Id: I752d7691c9c101b07c6ee85db83d96d9190bccd7 Reviewed-on: https://code.wireshark.org/review/1001 Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 543c566254..2bdc312a10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -309,8 +309,8 @@ if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_GCC_CHECKS)
check_c_compiler_flag(-Werror=unknown-warning-option WERR_UNKNOWN)
check_c_compiler_flag(-Werror WERROR)
else()
- unset(WERR_UNKNOWN)
- unset(WERROR)
+ set(WERR_UNKNOWN FALSE)
+ set(WERROR FALSE)
endif()
# string of additional compile command line flags for check_c_compiler_flag
if(WERR_UNKNOWN)