aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-06-14 10:48:22 +0200
committerJörg Mayer <jmayer@loplof.de>2014-06-14 08:49:51 +0000
commit30480da87a5032f61a19e30867a31392b92911be (patch)
treeae7bf425c8ff746037c18d054471d572860016f3 /CMakeLists.txt
parentb70bb4654a5c389100473ff343706df960ac63fd (diff)
Match for contents of WIRESHARK_SIMD_FLAGS only if non-empty
Change-Id: I99e15b237c74783b455461ce58ba32f1f8202990 Reviewed-on: https://code.wireshark.org/review/2208 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da74a2536f..f9fcf960a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -386,11 +386,12 @@ foreach(THIS_FLAG ${WIRESHARK_SIMD_TESTS})
endif()
endforeach()
-string(REGEX MATCH -msse4.2
- HAVE_SSE4_2
- ${WIRESHARK_SIMD_FLAGS}
-)
-message( STATUS "HAVE_SSE4_2: ${HAVE_SSE4_2}" )
+if ( ${WIRESHARK_SIMD_FLAGS} )
+ string(REGEX MATCH -msse4.2
+ HAVE_SSE4_2
+ ${WIRESHARK_SIMD_FLAGS}
+ )
+endif()
check_c_compiler_flag(-fvisibility=hidden FVHIDDEN)
if(FVHIDDEN)