aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-10 15:50:39 +0000
committerJoão Valverde <j@v6e.pt>2016-03-11 15:20:46 +0000
commit0ca383e5293b6cf322e8c143a65f455c10bc4096 (patch)
tree470b309d3f74717a7356ba5677f24d518d8f359c /CMakeLists.txt
parentf82c46c795419052208a2480f5625bd560e493e2 (diff)
cmake: Copy docs to build datafile dir for NSIS packaging.
Change-Id: Icc1f6dadc8bb082c4049cafc6a7e6c2d030ec85e Reviewed-on: https://code.wireshark.org/review/14409 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d00f645135..5ea1d553ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1322,6 +1322,27 @@ set(INSTALL_FILES
services
smi_modules
docbook/ws.css
+ ${CMAKE_BINARY_DIR}/doc/AUTHORS-SHORT
+ ${CMAKE_BINARY_DIR}/doc/asn2deb.html
+ ${CMAKE_BINARY_DIR}/doc/androiddump.html
+ ${CMAKE_BINARY_DIR}/doc/capinfos.html
+ ${CMAKE_BINARY_DIR}/doc/captype.html
+ ${CMAKE_BINARY_DIR}/doc/dftest.html
+ ${CMAKE_BINARY_DIR}/doc/dumpcap.html
+ ${CMAKE_BINARY_DIR}/doc/editcap.html
+ ${CMAKE_BINARY_DIR}/doc/extcap.html
+ ${CMAKE_BINARY_DIR}/doc/idl2deb.html
+ ${CMAKE_BINARY_DIR}/doc/idl2wrs.html
+ ${CMAKE_BINARY_DIR}/doc/mergecap.html
+ ${CMAKE_BINARY_DIR}/doc/randpkt.html
+ ${CMAKE_BINARY_DIR}/doc/randpktdump.html
+ ${CMAKE_BINARY_DIR}/doc/rawshark.html
+ ${CMAKE_BINARY_DIR}/doc/reordercap.html
+ ${CMAKE_BINARY_DIR}/doc/sshdump.html
+ ${CMAKE_BINARY_DIR}/doc/text2pcap.html
+ ${CMAKE_BINARY_DIR}/doc/tshark.html
+ ${CMAKE_BINARY_DIR}/doc/wireshark.html
+ ${CMAKE_BINARY_DIR}/doc/wireshark-filter.html
)
if(WIN32)
@@ -1567,6 +1588,7 @@ foreach(_install_file ${INSTALL_FILES})
"${_output_file}"
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
DEPENDS
+ docs
"${_install_file}"
)
list(APPEND copy_data_files_depends "${_output_file}")