aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-06-21 00:38:07 +0200
committerJörg Mayer <jmayer@loplof.de>2014-06-20 22:39:37 +0000
commitfd8bf42152161b4c4f7c8a87a415997c5ffeaba6 (patch)
tree452c447a7e95dc0445584cec01135aa746a13f25 /CMakeLists.txt
parentdc5d0ed0bc3e836ca8c25f01c8d30eb881d1c097 (diff)
Process all .in files, not only the ones needed for Unix'ish systems.
Change-Id: I265367f07253be4379efbb6689ec944f04ef6134 Reviewed-on: https://code.wireshark.org/review/2500 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt41
1 files changed, 40 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 721bf2208c..94c2389843 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -804,7 +804,46 @@ else()
endif()
configure_file(${CMAKE_SOURCE_DIR}/cmakeconfig.h.in ${CMAKE_BINARY_DIR}/config.h)
-configure_file(${CMAKE_SOURCE_DIR}/wireshark.pc.in ${CMAKE_BINARY_DIR}/wireshark.pc @ONLY)
+set( IN_FILES
+ image/libwireshark.rc.in
+ image/text2pcap.rc.in
+ image/capinfos.rc.in
+ image/wireshark.rc.in
+ image/mergecap.rc.in
+ image/tshark.rc.in
+ image/dumpcap.rc.in
+ image/reordercap.rc.in
+ image/rawshark.rc.in
+ image/file_dlg_win32.rc
+ image/tfshark.rc.in
+ image/editcap.rc.in
+ image/captype.rc.in
+ image/libwsutil.rc.in
+ image/filetap.rc.in
+ image/wiretap.rc.in
+ plugins/ethercat/plugin.rc.in
+ plugins/unistim/plugin.rc.in
+ plugins/opcua/plugin.rc.in
+ plugins/asn1/plugin.rc.in
+ plugins/wimax/plugin.rc.in
+ plugins/gryphon/plugin.rc.in
+ plugins/profinet/plugin.rc.in
+ plugins/m2m/plugin.rc.in
+ plugins/stats_tree/plugin.rc.in
+ plugins/wimaxasncp/plugin.rc.in
+ plugins/mate/plugin.rc.in
+ plugins/wimaxmacphy/plugin.rc.in
+ plugins/irda/plugin.rc.in
+ plugins/docsis/plugin.rc.in
+ plugins/easy_codec/plugin.rc.in
+ wireshark.pc.in
+)
+foreach( _in_file ${IN_FILES} )
+ get_filename_component( _path ${_in_file} PATH )
+ string( REGEX REPLACE "(.*)\\.in" "\\1" _outfile ${_in_file} )
+ configure_file( ${CMAKE_SOURCE_DIR}/${_in_file} ${CMAKE_BINARY_DIR}/${_outfile} @ONLY )
+endforeach()
+
if( ENABLE_GUIDES )
configure_file(
${CMAKE_SOURCE_DIR}/doxygen_global.cfg