aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-10-01 15:39:38 -0700
committerGerald Combs <gerald@wireshark.org>2015-10-02 15:52:24 +0000
commitfd5eafa50a77bc319a240727600be38307e54f86 (patch)
treeddd80c6ef88453bdafee66fb92fe687a998d4d2e /CMakeLists.txt
parent284f2ccf5cf72fb887c547ae9975f8c18c51bc7a (diff)
CMake: Don't feed -fPIC to Visual C++.
Change-Id: If6dd0619052b7735d7c5eb84aadc191545df7bee Reviewed-on: https://code.wireshark.org/review/10735 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59943aebb2..1f5e591547 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -873,7 +873,8 @@ if(HAVE_LIBZLIB)
endif()
if (Qt5Widgets_FOUND)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")
- if (Qt5_POSITION_INDEPENDENT_CODE)
+ if (Qt5_POSITION_INDEPENDENT_CODE AND NOT CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
+ # Qt 5.5's Qt5CoreConfigExtras.cmake adds "-fPIC".
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
endif()
set (QT_FOUND ON)